]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sudo/sudo_1.6.8p12-4.bb
2bc3d05219f12fa87265908f732b23b2f8e82bf3
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sudo / sudo_1.6.8p12-4.bb
1 DESCRIPTION = "Provide limited super user privileges to specific users"
2 LICENSE = "sudo"
3 HOMEPAGE = "http://www.sudo.ws/sudo/"
4 PRIORITY = "optional"
5 SECTION = "admin"
6
7 inherit autotools debian-vampyre
8
9 SRC_URI += "file://install-binaries.patch;patch=1 \
10            file://autofoo.patch;patch=1 \
11            file://noexec-link.patch;patch=1"
12
13 EXTRA_OECONF = "--with-editor=/bin/vi \
14                 --with-env-editor \
15                 --disable-setresuid \
16                 --libexecdir=${libdir}/sudo \
17                 --with-secure-path='/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin'"
18
19 do_configure_prepend () {
20         rm -f acsite.m4
21         if [ ! -e acinclude.m4 ]; then
22                 cat aclocal.m4 > acinclude.m4
23         fi
24 }
25
26 python __anonymous () {
27         bb.data.setVarFlag("do_install", "fakeroot", 1, d)
28 }
29
30 do_fix_perms () {
31         # fakeroot fucks this one up
32         chmod 0400 ${D}${sysconfdir}/sudoers
33 }