]> pilppa.org Git - libplp.git/blobdiff - src/Makefile.am
w1 independent file cleanups.
[libplp.git] / src / Makefile.am
index 7ad0d5a88c40c1e80566753a9af0fbc9de408f3e..183b03bd68abdeacce5d6f60badf3aa055fb6f7e 100644 (file)
@@ -1,6 +1,18 @@
 lib_LTLIBRARIES = libplp.la
 libplp_la_SOURCES = \
        config.c config.h \
+       Data.hh Data.cc \
+       DataReader.hh DataReader.cc \
+       Date.hh Date.cc \
+       Device.hh Device.cc \
+       DeviceConfig.hh DeviceConfig.cc \
+       DeviceData.hh DeviceData.cc \
+       DeviceTypes.hh \
+       FileUtil.cc FileUtil.hh \
+       SensorDevice.hh \
+       Store.cc Store.hh \
+       StoreDay.cc StoreDay.hh \
+       StoreCache.cc StoreCache.hh \
        log.h \
        log_config.c \
        str_util.c str_util.h \
@@ -13,4 +25,17 @@ libplpinclude_HEADERS =   \
         config.h \
         log.h \
         retval.h \
-        str_util.h
+        str_util.h \
+        Data.hh \
+        DataReader.hh \
+        Date.hh \
+        Device.hh \
+        DeviceConfig.hh \
+        DeviceData.hh \
+        DeviceTypes.hh \
+        FileUtil.hh \
+        SensorDevice.hh \
+        Store.hh \
+       StoreDay.hh \
+       StoreCache.hh
+