]> pilppa.org Git - libplp.git/blobdiff - src/Makefile.am
api fixes and cleanups
[libplp.git] / src / Makefile.am
index 9697c8bacc2f1939a1e2090873fdabcbf2eb29aa..58153f888e1ecb5137339a7c6b0efa87e63d83c6 100644 (file)
@@ -1,14 +1,44 @@
 lib_LTLIBRARIES = libplp.la
 libplp_la_SOURCES = \
-       retval.h \
+       config.c config.h \
+       Data.hh Data.cc \
+       DataSummary.hh DataSummary.cc \
+       DataReader.hh DataReader.cc \
+       Date.hh Date.cc \
+       Device.hh Device.cc \
+       DeviceData.hh DeviceData.cc \
+       DeviceConfig.hh DeviceConfig.cc \
+       DeviceTypes.hh \
+       FileUtil.cc FileUtil.hh \
+       SensorDevice.hh \
+       Store.cc Store.hh \
+       StoreDay.cc StoreDay.hh \
+       StoreCache.cc StoreCache.hh \
        log.h \
        log_config.c \
-       config.c config.h 
+       str_util.c str_util.h \
+       retval.h \
+       private/uci_config.c private/uci_config.h
 libplp_la_LDFLAGS = $(SRC_LIBS) $(all_libraries) -version-info 1:0:0 -no-undefined
 AM_CPPFLAGS = $(SRC_CFLAGS)
 DISTCLEANFILES = Makefile.in
 libplpincludedir=$(includedir)/plp
 libplpinclude_HEADERS =   \
-       retval.h \
+        config.h \
         log.h \
-        config.h
+        retval.h \
+        str_util.h \
+        Data.hh \
+        DataSummary.hh \
+        DataReader.hh \
+        Date.hh \
+        Device.hh \
+        DeviceData.hh \
+        DeviceConfig.hh \
+        DeviceTypes.hh \
+        FileUtil.hh \
+        SensorDevice.hh \
+        Store.hh \
+       StoreDay.hh \
+       StoreCache.hh
+