]> pilppa.org Git - libplp.git/blobdiff - src/Makefile.am
api fixes and cleanups
[libplp.git] / src / Makefile.am
index b815100f86732d42300ba088fe183f6fd441d777..58153f888e1ecb5137339a7c6b0efa87e63d83c6 100644 (file)
@@ -2,6 +2,7 @@ lib_LTLIBRARIES = libplp.la
 libplp_la_SOURCES = \
        config.c config.h \
        Data.hh Data.cc \
+       DataSummary.hh DataSummary.cc \
        DataReader.hh DataReader.cc \
        Date.hh Date.cc \
        Device.hh Device.cc \
@@ -16,7 +17,8 @@ libplp_la_SOURCES = \
        log.h \
        log_config.c \
        str_util.c str_util.h \
-       retval.h
+       retval.h \
+       private/uci_config.c private/uci_config.h
 libplp_la_LDFLAGS = $(SRC_LIBS) $(all_libraries) -version-info 1:0:0 -no-undefined
 AM_CPPFLAGS = $(SRC_CFLAGS)
 DISTCLEANFILES = Makefile.in
@@ -27,6 +29,7 @@ libplpinclude_HEADERS =   \
         retval.h \
         str_util.h \
         Data.hh \
+        DataSummary.hh \
         DataReader.hh \
         Date.hh \
         Device.hh \